Thunderbird Portable – incompatible addons

Довольно давно не обновлял свой почтовый клиент Mozilla Thunderbird, и наконец решился.

Пару слов о моем методе работы с Thunderbird. Использую исключительно портабельную версию, которая лежит в папке Dropbox – таким образом клиент с моими настройками, всей корреспонденцией и контактами всегда у меня под рукой, как на моем домашнем компьютере, так и на рабочем компьютере в студии, так и на ноутбуке и нетбуке. Плюс, конечно же, никаких времязатрат на настройку заново после переустановки системы. Плюс бэкап. Плюсов, в общем, очень много.

Побоявшись глюков и мусора при простом накате версии 7.0.1 “поверх” 3.0, решил заморочиться и поставить “с нуля”, все заново настроив. Седьмая версия порадовала – современный интерфейс, показалась более шустрой, улучшенная работа с вкладками, добавилась поддержка работы с таскбаром Windows 7.

(пардон за чужой скрин – на своем я бы задолбался затирать инфу, и выглядел бы скрин после этого не ахти :))

И вот с какой проблемой столкнулся. Я использую только 2 аддона к Thunderbird – это Zindus для синхронизации адресной книги птички и гугловских контактов, и MinimizeToTray Revived – для сворачивания клиента в системный трей (очень странно, что программа до сих пор не имеет этой функции изначально). Но после включения Thunderbird на другой машине обнаружил, что один из аддонов, а именно, MinimizeToTray – отказался запускаться, сетуя на “несовместимость с версией 7.0.1”. Видимо дело в том, что некоторые плагины при установке состояние своей совместимости пишут все же временно куда-то в реестр, нарушая портабельность приложения. Решение проблемы следующее:

Идем в Tools -> Options… -> Advanced -> General -> Config Editor…
Создаем параметр типа Boolean, называем его: extensions.checkCompatibility.7.0
Присваиваем ему значение False


Перезагружаем Thunderbird – и все, расширения заработали.

Просто теперь на вкладке аддонов будет красоваться извещение об отключенной проверке совместимости и кнопка на включение ее обратно. Для разных версий Громоптицы последние цифры в названии параметра будут разными, например 6.1, 6.1b (если бэта). Ну и стоить помнить, что действительно несовместимые плагины могут негативно повлиять на стабильность работы.